Subscribe on YouTube

Первоначальная настройка коммутатора Cisco Catalyst 2960G

Базовые настройки коммутатора Cisco Catalyst 2960G.

Данная статья также подойдет для настройки таких коммутаторов, как Cisco Catalyst 2950, Cisco Catalyst 2960, Cisco Catalyst 3550, Cisco Catalyst 3560, Cisco Catalyst 3560G.

Для первичных настроек коммутаторов Cisco, нам потребуется кабель RJ-45RS-232 и наличие COM-порта в компьютере.

В качестве консоли я буду использоваться ZOC.

Настройки подключения:

При первой загрузке устройства мастер установки предложит выполнить пошаговую настройку, отказываемся от этого шага:

Continue with configuration dialog? [yes/no]: no

После чего оказываемся в пользовательский режиме:

Switch>

Переходим в привилегированный режим:

Switch> enable
Password:
Switch#

Изменим имя коммутатора

Switch# configure terminal
Switch(config)# hostname C2960G-test (Задаем имя коммутатора – C2960G-test)
C2960G-test(config)#

Зададим IP-адрес для интерфейса управления коммутатором.

В моем случае я использую 24 порт коммутатора с управляющим Vlan-ом, в других вариациях можно настроить иные порты.

C2960G-test(config)#vlan 2
C2960G-test(config-vlan)#name ManagementVlan
C2960G-test(config-vlan)#ip address 10.0.10.111 255.255.255.0
C2960G-test(config-vlan)# exit
C2960G-test(config)# exit
C2960G-test(config)#interface GigabitEthernet0/24
C2960G-test(config-if)#switchport access vlan 2
C2960G-test(config-if)#no shutdown
C2960G-test(config-if)# exit
C2960G-test(config)# exit

Альтернативный вариант:

C2960G-test(config)# interface fa0/0
C2960G-test(config-if)# no shutdown
C2960G-test(config-if)# ip address 10.0.10.111 255.255.255.0
C2960G-test(config-if)# exit
C2960G-test(config)# exit

Установим пароль для привилегированного режима

C2960G-test(config)# enable secret pass1234example
C2960G-test(config)# exit
C2960G-test#

Установка пароля может быть выполнена командами password и secret. В первом случае пароль хранится в конфигурационном файле в открытом виде, а во втором - в зашифрованном. Если использовалась команда password, необходимо зашифровать пароли, хранящиеся в устройстве в открытом виде с помощью команды service password-encryption в режиме глобальной конфигурации.

Установим пароль для входа по telnet

C2960G-test(config)# line vty 0 5
C2960G-test(config-line)#password telnet-password

И разрешим вход по telnet:

C2960G-test(config-line)# login
C2960G-test(config)# exit

Зашифруем пароли, как я сообщал ранее:

C2960G-test(config)# service password-encryption

Если ошибиться при наборе чего-либо в консоле или ввести команду на русском, то Cisco попробует это отрезолвить, выключим эту особенность, чтобы не тратить время:

C2960G-test(config)# no ip domain-lookup

Зададим имя домена:

C2960G-test(config)# ip domain-name example-domain.com

Зададим IP-адрес DNS сервера:

C2960G-test(config)# ip name-server 192.168.2.6

Чтобы по команде show logging отображалось нормальное время, а не количествово дней и прочее пропишем:

C2960G-test(config)# service timestamps log datetime localtime

Настроим access-list для доступа к свичу только с указанных IP-адресов:

C2960G-test(config)# ip access-list standard TELNET
C2960G-test(config-std-nacl)# permit 192.168.2.10
C2960G-test(config-std-nacl)# permit 192.168.2.6
C2960G-test(config-std-nacl)# exit

Применим этот access-list:

C2960G-test(config)# line vty 0 5
C2960G-test(config-line)# access-class TELNET in

Зададим timeout активности telnet сессии, по истечении указанного времени, если в консоли ничего не вводилось, то telnet соединение будет автоматически закрываться:

C2960G-test(config-line)# exec-timeout 5 0
C2960G-test(config-line)# exit

Напоследок сохраняемся:

C2960G-test# copy running-config startup-config

или

C2960G-test# wr
Поделиться Комментарии